ℹ️

Secondary SASE Health

You've been redirected to our secondary SASE Health because the primary site is currently undergoing maintenance.

All service availability data displayed here is identical to the primary SASE Health.

⚠️ Important: Subscription and notification management for emails is temporarily unavailable on this page.

Contact Support

Next-Gen Trust Security (NGTS) : We are investigating failures in creating new tenants on NGTS

Incident Report for Prisma SASE

Resolved

Status: Resolved

Severity: Degraded

Locations: Ashburn, Frankfurt, London, Singapore, Sydney, Toronto

Impact:

We are currently investigating an issue preventing the creation of new tenants on NGTS. Existing tenants and their functionality are unaffected and operating normally.

Workaround:

None


The incident has been fully resolved and all services are operational.

Posted Jul 25, 2026 - 01:11 UTC

Investigating

Status: Investigating

Severity: Degraded

Locations: Ashburn, Frankfurt, London, Singapore, Sydney, Toronto

Impact:

We are currently investigating an issue preventing the creation of new tenants on NGTS. Existing tenants and their functionality are unaffected and operating normally.

Workaround:

None


An incident has been identified. We are actively investigating to restore services.

Posted Jul 24, 2026 - 16:22 UTC
This incident affected: Next-Gen Trust Security (NGTS).