ℹ️

Secondary SASE Health

You've been redirected to our secondary SASE Health because the primary site is currently undergoing maintenance.

All service availability data displayed here is identical to the primary SASE Health.

⚠️ Important: Subscription and notification management for emails is temporarily unavailable on this page.

Contact Support

Prisma Browser : PAB downloads from https://get.pabrowser.com/welcome are failing

Incident Report for Prisma SASE

Resolved

Status: Resolved

Severity: Disruption

Locations: Council Bluffs, Doha, Frankfurt, Hong Kong, Jakarta, Johannesburg, London, Los Angeles, Madrid, Milan, Montreal, Mumbai, Paris, Riyadh, Seoul, Singapore, St. Ghislain, Sydney, Taipei, Tel Aviv, Tokyo, Toronto, Warsaw, Zurich

Impact:

Update: The team has identified the issue and applying a fix.




End users currently are not able to download the browser application from [https://get.pabrowser.com/welcome]

Workaround:

MDM installed organizations or sharing the binary internally enable users to install the browser


The incident has been fully resolved and all services are operational.

Posted Aug 31, 2026 - 11:03 UTC

Monitoring

Status: Monitoring

Severity: Disruption

Locations: Council Bluffs, Doha, Frankfurt, Hong Kong, Jakarta, Johannesburg, London, Los Angeles, Madrid, Milan, Montreal, Mumbai, Paris, Riyadh, Seoul, Singapore, St. Ghislain, Sydney, Taipei, Tel Aviv, Tokyo, Toronto, Warsaw, Zurich

Impact:

Update: The team has identified the issue and applying a fix.




End users currently are not able to download the browser application from [https://get.pabrowser.com/welcome]

Workaround:

MDM installed organizations or sharing the binary internally enable users to install the browser


A fix has been implemented and the issue is resolved. We are actively monitoring to ensure full restoration of services.

Posted Aug 31, 2026 - 10:58 UTC

Investigating

Status: Investigating

Severity: Disruption

Locations: Council Bluffs, Doha, Frankfurt, Hong Kong, Jakarta, Johannesburg, London, Los Angeles, Madrid, Milan, Montreal, Mumbai, Paris, Riyadh, Seoul, Singapore, St. Ghislain, Sydney, Taipei, Tel Aviv, Tokyo, Toronto, Warsaw, Zurich

Impact:

End users currently are not able to download the browser application from [https://get.pabrowser.com/welcome]

Workaround:

MDM installed organizations or sharing the binary internally enable users to install the browser


An incident has been identified. We are actively investigating to restore services.

Posted Aug 31, 2026 - 10:47 UTC
This incident affected: Prisma Browser (Browser Updates).